WAMP behaving oddly
Posted by: Charlene (---.sip.asm.bellsouth.net)
Date: December 26, 2005 06:51PM

When I go to [localhost] in firefox or IE, it waits for a long time (loading?) then says that Apache has crashed. When I try to reference a subdirectory, though, eg., where I'm working on a project or phpmyadmin, it doesn't crash and works just fine. This is both for Apache 1.3 and 2 (the latest two releases; I was running WAMP 1.4something before with no problems). I'm running Windows XP tablet pc edition (more akin to Pro than Home). Any ideas why this may be happening?

Re: WAMP behaving oddly
Posted by: Daniel (---.westman.wave.ca)
Date: December 26, 2005 11:20PM

I am experiencing this aswell. It started happening as soon as I changed the MySQL login from the default (root with no password). Before that I was able to view the homepage just fine.

Re: WAMP behaving oddly
Posted by: Paradox (---.swipnet.se)
Date: December 27, 2005 12:49AM

1: Uninstall wamp
2: [www.wampserver.com]
3: Install it agan

Re: WAMP behaving oddly
Posted by: Daniel (---.westman.wave.ca)
Date: December 27, 2005 08:42AM

Just did that, didn't work (didn't find any of those in the registry) so I installed and looked through index.php (WAMP homepage)

If you don't have phpMyAdmin setup with the config authentication method, you may not have $cfg['Servers'][$i]['password'] filled in (config.inc.php in phpMyAdmin directory). This causes mysqli_connect to crash the server.


1. You can simply give $cfg['Servers'][$i]['password'] (line 73, config.inc.php in phpMyAdmin directory) the value of your mysql password.

OR, if you don't want to put your password in the config.inc.php file...

2. Substitute $cfg['Servers'][1]['password'] on lines 91 and 98 of index.php (WAMP homepage) for your mysql password.

Re: WAMP behaving oddly
Posted by: Romain Bourdon (---.w193-251.abo.wanadoo.fr)
Date: December 27, 2005 11:48AM

All this is linked to a PHP 5.1.1 bug on windows. If your database (like mysql) connection parameters aren't good, it makes apache crash. Should be solved with good parameters or in the next PHP version.


Sorry, only registered users may post in this forum.