Wamp does not start services after windows 10 update
Posted by: johnny_bravo (---.14-87-r.retail.telecomitalia.it)
Date: July 30, 2015 09:40PM

Hi all,
Yesterday I installed windows 10, and wamp does not start services.. I have the red icon.
What can I do?
I use wamp for a local joomla installation and I don't know how can I download the database from phpmyadmin to save my site.

Thank you in advance!

Re: Wamp does not start services after windows 10 update
Posted by: RiggsFolly (---.as43234.net)
Date: July 30, 2015 11:36PM

Hi Johnny,

The W10 install will have over wirtten all knowledge of the Apache and MySQL services.

Dont Panic: All you need to do is

Start WampServer
left click wampmanager -> Apache -> Services -> Install Service
left click wampmanager -> MySQL -> Services -> Install Service


Stop WampServer

Start WampServer


It should be fine now.

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.2.5 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.23>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Re: Wamp does not start services after windows 10 update
Posted by: denver49 (---.hlrn.qwest.net)
Date: July 31, 2015 01:59AM

Windows Process Activation Service may be the culprit, after upgrading to Windows 10 from Windows 7, this was the running service locked onto port 80. Not sure what the ramifications are for turning off this service.

Re: Wamp does not start services after windows 10 update
Posted by: RiggsFolly (---.as43234.net)
Date: July 31, 2015 10:11AM

Hi Denver,

Hmmm, thanks for the post,
this one may cause a few interesting situations.

[technet.microsoft.com]
[msdn.microsoft.com]

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.2.5 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.23>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Re: Wamp does not start services after windows 10 update
Posted by: neobradovic (---.180.246.208.targo.rs)
Date: July 31, 2015 12:05PM

Wamp server doesn't work on windows 10 i updated yesterday. I done everything you sad and nothing. Please hellp

Re: Wamp does not start services after windows 10 update
Posted by: johnny_bravo (---.14-87-r.retail.telecomitalia.it)
Date: July 31, 2015 12:37PM

Hi all!
First, thank you for the replies!

I tried to do what RiggsFolly said but the message that comes out for Apache is this:

Your port 80 is actually used by :
Server: Microsoft-IIS/10.0
Cannot install the Apache service, please stop this application and try again.
Press Enter to exit...

For the MySQL service it don't shows anything...

sad smiley

Re: Wamp does not start services after windows 10 update
Posted by: RiggsFolly (---.as43234.net)
Date: July 31, 2015 12:40PM

Hi Neo,

It does work on Windows-10, I have been using it on the preview for month now. It has never skipped a beat.

There could be many reasons why an install of a new OS has caused you a hiccup.

Please start by

1) Starting a new Thread
2) Including the answer to these question in your first post READ BEFORE YOU ASK A QUESTION

There are also a few troubleshooting hint in that document that may help.


Look forward to your question

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.2.5 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.23>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Re: Wamp does not start services after windows 10 update
Posted by: RiggsFolly (---.as43234.net)
Date: July 31, 2015 12:45PM

Hi Johnny,

Right so for some reason MS think installing IIS ( their web server ) on every new desktop install of W10 is a good idea. I cant think why.


I assume you are not using it or you would know what it was, so I suggest you Uninstall it.
You can find HOWTO's on the web, probably better than me telling you how.

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.2.5 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.23>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Sorry, only registered users may post in this forum.