wampserver icon not available in toolbar on automatic start
Posted by: rpjd (79.97.242.---)
Date: April 16, 2015 01:18PM

I don't remember seeing an option to start wampserver automatically on startup during installation. There is an option to start wampserver automatically on startup through Control Panel->Administrative Tools->Services and right-click on wampserver64 which I selected. After restarting my laptop, services shows wampserver64 as running, but the wampserver icon is not displayed on the toolbar or available icons. I have to run/select wampserver from the start menu or taskbar to get the wampsever icon to appear (in green) on the toolbar. Is this a bug?

Options: ReplyQuote
Re: wampserver icon not available in toolbar on automatic start
Posted by: RiggsFolly (---.as43234.net)
Date: April 16, 2015 02:34PM

Hi

No. Not a bug.

You autostarted Apache. I think you will find that the service you autostarted was called wampapache64.
This also means you forgot to autostart MySQL (wampmysqld64), which can be done in the same way.

The icon that sits in the system tray is wampmanager.exe ( its not a service )!

You could autostart that by copying the WAMPManager icon from the start menu to the "Startup" folder in the Start menu, All Programs list if you wanted to, but that would not autostart Apache and MySQL.

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.8 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 6.3.10>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: wampserver icon not available in toolbar on automatic start
Posted by: rpjd (79.97.242.---)
Date: April 16, 2015 02:48PM

If wampmanager is started manually, both wampapache64 and wampmysqld64 are started automatically if configured correctly, but not if wampmamager is auto-started. Why? No logic to that at all.

Options: ReplyQuote
Re: wampserver icon not available in toolbar on automatic start
Posted by: RiggsFolly (---.as43234.net)
Date: April 16, 2015 05:44PM

Can I ask what version of WAMPServer you are using please. Could you answer these questions entitles Read before you sak a question

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.8 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 6.3.10>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: wampserver icon not available in toolbar on automatic start
Posted by: rpjd (79.97.242.---)
Date: April 16, 2015 05:53PM

I am using the latest version of wampserver: apache2.4.9, php5.5.12, mysql5.6.17, phpmyadmin4.4.1.1

Options: ReplyQuote
Re: wampserver icon not available in toolbar on automatic start
Posted by: RiggsFolly (---.as43234.net)
Date: April 16, 2015 06:34PM

[forum.wampserver.com]

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.8 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 6.3.10>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: wampserver icon not available in toolbar on automatic start
Posted by: sTimulated (---.plus.com)
Date: April 17, 2015 06:33PM

Right click on wampmanager.exe
send to (desktop)
right click on that shortcut and cut
click on start,all programs and right click open on startup
paste into this folder

wamp will start up when you boot.

icons do not automattically show in the tray.
click on the up arrow,show hidden icons
click on customize
change wamp icon to show icon and notifications.

Options: ReplyQuote


Sorry, only registered users may post in this forum.