403 Fobidden configuring vhosts
Posted by: rpjd (79.97.242.---)
Date: April 02, 2015 03:14AM

I have installed the latest version of wampserver 2.5, which is running fine. I'm trying to set up virtual hosts.
The files I need to change are (as far as I know):
wamp/bin/apache/apache2.4.9/conf/extra/httpd-vhosts.conf
<VirtualHost *:80>
DocumentRoot "c:/wamp/www/Project" //example
ServerName Project
</VirtualHost>

c:/windows/systems32/drivers/etc/hosts
127.0.0.1 Project

wamp/bin/apache/apache2.4.9/conf/httpd.conf
Include conf/extra/httpd-vhosts.conf

I restart the server and refresh localhost after editing each file, so I know if editing a file is causing any issues with localhost. Everything is fine after editing the first two files above. After I uncomment
Include conf/extra/httpd-vhosts.conf and restart the server I get a 403 Forbidden error on localhost.

Can anyone advise me what could be causing this? Or am I missing something?

Options: ReplyQuote
Re: 403 Fobidden configuring vhosts
Posted by: RiggsFolly (---.as43234.net)
Date: April 02, 2015 10:05AM

Hello,

The problem is your vhost definition of the Project.
Also you need to define localhost as a vhost as well as the original defineition in httpd.conf is ignored when virtual hosts are used.

See this Sticky Post for how to set it up correctly WAMPServer 2.5 The Homepage, Your Projects Menu and the need for Virtual Hosts

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.8 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.16>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: 403 Fobidden configuring vhosts
Posted by: rpjd (79.97.242.---)
Date: April 02, 2015 10:27AM

Many Thanks RiggsFolly.

Options: ReplyQuote


Sorry, only registered users may post in this forum.