LocalHost doesn't work
Posted by: peterfgoossens@gmail.com (---.cpe.cableonda.net)
Date: March 14, 2015 01:59PM

Although the server shows online, localhost or 127.0.0.1 are not working; only a blank page appears

Windows 7 64 bits
Wampserver 2.5 64 bits
Apache: 2.4.9
PHP: 5.5.12
MySQL: 5.6.17

Color: Orange (says online)

Apache error log, MySQL error log and PHP error log: all empty

Windows eventvwr: Does not show any name Appache Srevice or MySQL

hosts shows:
127.0.0.1 localhost
127.0.0.1 localhost
127.0.0.1 localhost

Options: ReplyQuote
Re: LocalHost doesn't work
Posted by: RiggsFolly (---.as43234.net)
Date: March 15, 2015 08:55AM

Hi Peter,

The colour of the W icon is more important than the "Online" status.

If the W icon is orange then one of the services ( wampapache or wampmysqld ) has not started.

In your case it sounds like the service that has not started is Apache.


On a normal Startup, both Apache and MySQL write some information to the Apache and MySQL error logs, so if your logs are empty I can only assume that you have another version of MySQL and possible Apahce running on your system, is that correct?

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.2.8 32bit & 64bit) Aestan Tray Menu 3.2.4.7
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.23>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: LocalHost doesn't work
Posted by: jvelte (---.BELIEVEWIRELESS.NET)
Date: March 17, 2015 06:01PM

I am by no means an expert, but was having this same issue. RiggsFolly you were correct, the Apache service hadn't started. I did the following to solve the issue:

Left click the Wamp Icon
Navigate to Apache>Service
Click 'install service'
I then navigated back to this same menu and clicked 'start/resume service' (this option was not available until I installed the service)
I then had to allow the Apache Service through Windows Security (this was an automatic pop-up screen)
Next launch my code executed!

Options: ReplyQuote
Re: LocalHost doesn't work
Posted by: InvisibleMonkey (---.range109-149.btcentralplus.com)
Date: March 17, 2015 11:11PM

Could be you've something else running on port 80 (default). I did under Win 7 x64.

Solution (if it is this): open Apache->httpd.conf in a decent editor (i.e. not notepad) (by default it's in C:\wamp\bin\apache\apache2.4.9\Conf).

Change:

Listen 0.0.0.0:80
Listen [::0]:80

to

Listen 0.0.0.0:8080
Listen [::0]:8080

Try starting Apache and then open localhost:8080 in a browser.

(Or you could stop whatever's using port 80, although I'd go with a port change.)

Options: ReplyQuote
Re: LocalHost doesn't work
Posted by: RiggsFolly (---.as43234.net)
Date: March 23, 2015 12:07PM

Ok Peter,

Lets start from the beginning.

you say you get a blank page when you try and run `localhost` or `127.0.0.1` from the broser.

This would appaer to indicate that Apache has not started.

Can you look at the Windows service snapin so we can be sure of this please. To do that do

Press the "Windows Key" + R
enter `services.msc` and press `OK` button.

Look down the list of services for
1. wampapache64
2. wampmysqld64

Tell me which of these 2 services HAS NOT STARTED

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.2.8 32bit & 64bit) Aestan Tray Menu 3.2.4.7
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.23>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: LocalHost doesn't work
Posted by: peterfgoossens@gmail.com (---.cpe.cableonda.net)
Date: April 04, 2015 05:45PM

Thanks for having gotten back to me. Wampapache64 has not started

Options: ReplyQuote
Re: LocalHost doesn't work
Posted by: peterfgoossens@gmail.com (---.cpe.cableonda.net)
Date: April 04, 2015 06:00PM

In the meantime, I did the following in reaction to the 2 other suggestions: I changed the port 80 to the port 8080 and indeed I got the apache running. However, when I run localhost, I get the same blank screen

Options: ReplyQuote
Re: LocalHost doesn't work
Posted by: Yourpcmedic (---.buffalo.res.rr.com)
Date: April 04, 2015 09:16PM

I am having the same issue and am at the same spot. changing port 80 to 8080 has allowed the apache service to start, but localhost is still blank. I am running win8.1 64bit. Apache version 2.4.9, PHP 5.5.12 and MySQL 5.6.17. My Programs and features listing also shows a MySQL Server 5.1 as being installed. from publisher MySQL AB.

Options: ReplyQuote
Re: LocalHost doesn't work
Posted by: RiggsFolly (---.as43234.net)
Date: April 05, 2015 04:53PM

Media,

Have you installed MySQL Workbench?

Running 2 MySQL servers on the same machine is a bit complex, well you need to set them both to start up manually rahter than automatically ( i.e. at boot time ) so you only satrt one at a time.



If you can I would uninstall the ther MySQL, but dont forget to backup any databases before you ininstall it,

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.2.8 32bit & 64bit) Aestan Tray Menu 3.2.4.7
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.23>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: LocalHost doesn't work
Posted by: Dog_Doc22 (---.hsd1.ga.comcast.net)
Date: April 07, 2015 05:12AM

I just had the same thing happen, though it was my doing:

In my virtual hosts, I ended the 'DocumentRoot' directory with a trailing slash (/). Knew it immediately when I looked at the Event Viewer > Administrative Logs, "Document Root must be a directory." Silly me.

Just thought I'd post this in case anyone else finds this thread and has fat fingered it like I did.

Options: ReplyQuote
Re: LocalHost doesn't work
Posted by: GulzarAlam (---.banglalionwimax.com)
Date: April 09, 2015 11:28PM

Hi Guy's,

Just got such same trouble and lucklly found the solution. Hear it is if any one need.

go in skype->tools->options->advanced and UN-check use ports 80 & 443.

If you still get the problem then use InvisibleMonkey's solution.

Options: ReplyQuote
Re: LocalHost doesn't work
Posted by: GulzarAlam (---.banglalionwimax.com)
Date: April 09, 2015 11:28PM

Hi Guy's,

Just got such same trouble and luckily found the solution. Hear it is if any one need.

go in skype->tools->options->advanced and UN-check use ports 80 & 443.

If you still get the problem then use InvisibleMonkey's solution.

Options: ReplyQuote
Re: LocalHost doesn't work
Posted by: peterfgoossens@gmail.com (---.cpe.cableonda.net)
Date: April 09, 2015 11:44PM

Gulzar: That solves the apache issue, but not the blank screen!

Options: ReplyQuote
Re: LocalHost doesn't work
Posted by: RiggsFolly (---.as43234.net)
Date: April 13, 2015 12:17PM

I assume you are using this url

'http://localhost:8080' (without the quotes) to get to the localhost site when you change the Listen statement to use port 8080?

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.2.8 32bit & 64bit) Aestan Tray Menu 3.2.4.7
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.23>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-



Edited 1 time(s). Last edit at 04/13/2015 12:17PM by RiggsFolly.

Options: ReplyQuote
Re: LocalHost doesn't work
Posted by: peterfgoossens@gmail.com (---.cpe.cableonda.net)
Date: April 17, 2015 04:19PM

OK, the following happened. I had uninstalled wampserver and reinstalled it. I theN changed the port to 8080 as above, but now apache does not want to start anymore. When I press "start nrvice" from services.msc I get an error: sERVICE SPECIFIC ERROR CODE 1

Options: ReplyQuote
Re: LocalHost doesn't work
Posted by: peterfgoossens@gmail.com (---.cpe.cableonda.net)
Date: April 18, 2015 05:49PM

I got it to work! I changed the port in use by Skype (80) uninstalled and re-installed wampserver and "voilá".

So my conclusion is: Changing the listen statement in Server Configuration doesn't work because Apache continuous to look for port 80 (eventvwr).

Thank to all!

Options: ReplyQuote
Re: LocalHost doesn't work
Posted by: Oyvind (---.209.55.115.getinternet.no)
Date: May 06, 2015 10:31PM

Hi,

I have a website which I have downloaded locally. The database from the live site I have imported in Wamp (with same database name as on the live site).

My localhost site loads correctly (http://127.0.0.1/ or [localhost]), but when I click on other pages on the site, it redirects immediately to the live site pages and does not stay on the local host pages..

In the file (Wordpress) wp-config I have changed:

/** Name for the WordPress-database */
define(‘DB_NAME’, ‘mydatabasename’);

/** MySQL-database username */
define(‘DB_USER’, ‘root’);

/** MySQL-database password */
define(‘DB_PASSWORD’, ”);


Any suggestions?


Thanks.

Øyvind

Options: ReplyQuote
Re: LocalHost doesn't work
Posted by: RiggsFolly (---.as43234.net)
Date: May 07, 2015 02:06AM

Please check the WordPress site for the things you need to check/change when moving a wordpress site.

[codex.wordpress.org]

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.2.8 32bit & 64bit) Aestan Tray Menu 3.2.4.7
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.23>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote


Sorry, only registered users may post in this forum.