Pages: 12Next
Current Page: 1 of 2
WampServer doesn't start on Windows 10
Posted by: Cell Guy (---.hsd1.va.comcast.net)
Date: January 20, 2015 11:27PM

I just installed WS on the W10 tech preview and it doesn't start. The PHP & Apache error logs are empty, and the MySQL log doesn't have any errors in it.

Any ideas why WS wouldn't start up on Windows 10?

Options: ReplyQuote
Re: WampServer doesn't start on Windows 10
Posted by: RiggsFolly (---.as43234.net)
Date: January 21, 2015 12:41AM

Hi Cell,

I have had it running on the W10 Preview build 9841 and build 9879(the current build I believe)

Please remember W10 is preview software not a fully finished release.

You have to download the required MSVC C++ runtime libraries as these do not come with EITHER of these preview releases.

If you are using WAMPServer 2.5(32bit) you will need to download and install these 2 runtimes

Microsoft Visual C++ 2012 Redistributable Package (x86)]
Check the VSU_4\vcredist_x86.exe option and click NEXT


If you are using WAMPServer 2.5(64bit) you will need to download and install these 3 runtimes

Microsoft Visual C++ 2012 Redistributable Package (x64)]
Check the VSU_4\vcredist_x64.exe option and click NEXT


Finally make sure you have checked the HOSTS file C:\windows\system32\drivers\etc\hosts

remove the '#' comment from these 2 lines

127.0.0.1  localhost
::1   localhost

If you are using earlier versions of WAMPServer then see this post for a list of all the possible Microsoft C/C++ Runtime Libraries that you may need to install to get the earlier versions of Apache and PHP running.
List of possible MS C/C++ runtimes required for various versions of Apache and PHP

---------------------------------------------------------------------------------------------
(Windows 7 Pro 32bit) (Wampserver 3.0.6 32bit)
<Apache 2.4.23/2.2.31> <PHP 7.1.2/7.0.16/5.6.28/5.5.38/5.4.45/5.3.29> <MySQL 5.7.10/5.6.17/5.5.28>
<MariaDB 10.1.21> <phpMyAdmin4.6.5.2> <MySQL Workbench 6.3.6.511>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin -- WAMPServer alternate Repo
-?-?-?- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -?-?-?-



Edited 3 time(s). Last edit at 03/17/2015 02:43PM by RiggsFolly.

Options: ReplyQuote
Re: WampServer doesn't start on Windows 10
Posted by: Cell Guy (---.hsd1.va.comcast.net)
Date: January 21, 2015 07:02PM

RiggsFolly,

Thanks so much fory our help. I updated to build 9879 and installed the visual c++ redistributable packages. I now have the following installed:

[imageshack.com]

But unfortunately WampServer still doesn't start up.

Do you have any other ideas on what the problem might be?

Thanks again for your help.

Options: ReplyQuote
Re: WampServer doesn't start on Windows 10
Posted by: Kirk (---.dhcp.stcd.mn.charter.com)
Date: January 21, 2015 07:09PM

Cell Guy,

Do you happen to have Skype installed? If so make sure that it isn't using port 80 if you haven't already.

Options: ReplyQuote
Re: WampServer doesn't start on Windows 10
Posted by: RiggsFolly (---.as43234.net)
Date: January 21, 2015 07:20PM

What color is your Wampmanager icon.

If its Orange then which service is not starting?

---------------------------------------------------------------------------------------------
(Windows 7 Pro 32bit) (Wampserver 3.0.6 32bit)
<Apache 2.4.23/2.2.31> <PHP 7.1.2/7.0.16/5.6.28/5.5.38/5.4.45/5.3.29> <MySQL 5.7.10/5.6.17/5.5.28>
<MariaDB 10.1.21> <phpMyAdmin4.6.5.2> <MySQL Workbench 6.3.6.511>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin -- WAMPServer alternate Repo
-?-?-?- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -?-?-?-

Options: ReplyQuote
Re: WampServer doesn't start on Windows 10
Posted by: Cell Guy (---.hsd1.va.comcast.net)
Date: January 21, 2015 08:03PM

I did install Skype, but it's not running.

The icon is orange.

The MySQL log doesn't show any errors. The PHP and Apache error logs haven't been created. When I try opening them from the WS menu, notepad says the files don't exist and asks if I want to create them, which I assume means there haven't been any errors?



Edited 1 time(s). Last edit at 01/21/2015 08:03PM by Cell Guy.

Options: ReplyQuote
Re: WampServer doesn't start on Windows 10
Posted by: Cell Guy (---.hsd1.va.comcast.net)
Date: January 21, 2015 08:16PM

I ran "netstat -aon | findstr :80" in cmd and it doesn't look like anything is using port 80. I also looked in the Event Viewer and don't see any messages from Apache or PHP.

Options: ReplyQuote
Re: WampServer doesn't start on Windows 10
Posted by: Cell Guy (---.hsd1.va.comcast.net)
Date: January 21, 2015 08:22PM

Out of curiosity I tried running httpd.exe from command prompt and it gave the following errors through popup dialogs, one after the other:

PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.5.12/ext/php_intl.dll' - The specified module could not be found.

PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.5.12/ext/php_ldap.dll' - The specified module could not be found.

PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.5.12/ext/php_intl.dll' - The specified module could not be found.

PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.5.12/ext/php_ldap.dll' - The specified module could not be found.

Options: ReplyQuote
Re: WampServer doesn't start on Windows 10
Posted by: Cell Guy (---.hsd1.va.comcast.net)
Date: January 21, 2015 09:24PM

Both of those files are in the \ext folder, and I added these values to the system PATH variable:

C:\wamp\bin\php\php5.5.12;
C:\wamp\bin\php\php5.5.12\php.exe;
C:\wamp\bin\php\php5.5.12\ext;

Options: ReplyQuote
Re: WampServer doesn't start on Windows 10
Posted by: Cell Guy (---.hsd1.va.comcast.net)
Date: January 21, 2015 11:17PM

I didn't restart my computer after adding those directories to the PATH variable. After restarting, I no longer get the popup DLL errors when starting httpd.exe through cmd.

When I start WS through the desktop icon the icon in the system tray goes to orange and stays there. No errors are written to apache_error.log or php_error.log. When I try browsing to "localhost," the page doesn't load.

However, if I close WS and then run httpd.exe through cmd, I can load "localhost" in my browser! When I run it through cmd, the following is written to apache_error.log:


[Wed Jan 21 17:15:52.484887 2015] [mpm_winnt:notice] [pid 8676:tid 500] AH00455: Apache/2.4.9 (Win32) PHP/5.5.12 configured -- resuming normal operations
[Wed Jan 21 17:15:52.484887 2015] [mpm_winnt:notice] [pid 8676:tid 500] AH00456: Apache Lounge VC11 Server built: Mar 16 2014 12:13:13
[Wed Jan 21 17:15:52.484887 2015] [core:notice] [pid 8676:tid 500] AH00094: Command line: 'httpd.exe -d C:/wamp/bin/apache/apache2.4.9'
[Wed Jan 21 17:15:52.485887 2015] [mpm_winnt:notice] [pid 8676:tid 500] AH00418: Parent: Created child process 8160
[Wed Jan 21 17:15:52.947119 2015] [mpm_winnt:notice] [pid 8160:tid 536] AH00354: Child: Starting 64 worker threads.

Any idea why WS still isn't working properly?

Options: ReplyQuote
Re: WampServer doesn't start on Windows 10
Posted by: RiggsFolly (---.as43234.net)
Date: January 21, 2015 11:32PM

You should not UNDER ANY CIRCUMSTANCES add anything to do with WAMpservr to the System PATH.

Please remove all those entries.


This makes no sence, if you are seeing these errors
PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.5.12/ext/php_intl.dll' - The specified module could not be found.

I have to assume that Apache has started.


Please view your Windows Event Log and look for errors from APACHE, what errors are you getting

---------------------------------------------------------------------------------------------
(Windows 7 Pro 32bit) (Wampserver 3.0.6 32bit)
<Apache 2.4.23/2.2.31> <PHP 7.1.2/7.0.16/5.6.28/5.5.38/5.4.45/5.3.29> <MySQL 5.7.10/5.6.17/5.5.28>
<MariaDB 10.1.21> <phpMyAdmin4.6.5.2> <MySQL Workbench 6.3.6.511>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin -- WAMPServer alternate Repo
-?-?-?- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -?-?-?-

Options: ReplyQuote
Re: WampServer doesn't start on Windows 10
Posted by: Cell Guy (---.hsd1.va.comcast.net)
Date: January 22, 2015 02:54AM

I think it's working!

I actually stumbled across a stackoverflow answer you posted and tried left clicking on system tray icon->apache->service->start/resume

Then the icon went green! So it looks like for whatever reason Apache was not starting automatically.

Thank you so much for your help!

Options: ReplyQuote
Re: WampServer doesn't start on Windows 10
Posted by: praveenpuglia (182.19.66.---)
Date: March 17, 2015 08:47AM

In all the machines that I have tried windows 10 technical preview, it didnt work initially because of a windows service.

Here...
[praveenpuglia.com]

I have posted couple of workarounds which should get it working.

Options: ReplyQuote
Re: WampServer doesn't start on Windows 10
Posted by: RiggsFolly (---.as43234.net)
Date: March 17, 2015 10:14AM

Praveen,

The World Wide Web Publishing Services is part of and installed with IIS, and is therefore covered by many posts here suggesting that you

a) Do not install IIS

b) If its installed, as some installs of W7 and W8 and now apparently W10 do install it by default. Then uninstall it, or disable the services while using Apache.

As of the current build (9926) of W10 Preview, the only thing you need to do to get WAMPServer 2.5 running is install the MSVC2012 VC11 C/C++ runtime library as this is not delivered as part of the W10 install.

Also you suggestion for changing Apache's Listening port is incomplete.

If you want to publicise your web site, plese make the information correct and keep it current, otherwise I will ask a moderator to remove posts that are obviously just for self publicity.

---------------------------------------------------------------------------------------------
(Windows 7 Pro 32bit) (Wampserver 3.0.6 32bit)
<Apache 2.4.23/2.2.31> <PHP 7.1.2/7.0.16/5.6.28/5.5.38/5.4.45/5.3.29> <MySQL 5.7.10/5.6.17/5.5.28>
<MariaDB 10.1.21> <phpMyAdmin4.6.5.2> <MySQL Workbench 6.3.6.511>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin -- WAMPServer alternate Repo
-?-?-?- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -?-?-?-



Edited 1 time(s). Last edit at 07/31/2015 02:54PM by RiggsFolly.

Options: ReplyQuote
Re: WampServer doesn't start on Windows 10
Posted by: praveenpuglia (182.19.66.---)
Date: March 17, 2015 12:50PM

I really didn't have the intention to publicize my website. Neither I found a place wherein this was mentioned via Googling.

Since it was too long to post what I have in the website, I didnt copy paste. I am sorry if It was put in a wrong way. I can always take the link down smiling smiley

I had the awareness that it's something that comes with IIS but I was not sure if I could remove it from the system without causing a trouble. As you mentioned, Windows 10 by default installs it. May be because the technical preview we use isnt the consumer version.

Regarding the VC++, I didn't mention it since while downloading WAMP, it's always mentioned to have that as a necessary requirement. So when I installed WAMP, I didnt have that issue. Hence never knew.

What do you mean by incomplete? Those are the exact steps I follow to change the default port. I would be happy to know if there is anything I missed as a correction.

Options: ReplyQuote
Re: WampServer doesn't start on Windows 10
Posted by: zolyyy (---.pool.digikabel.hu)
Date: July 31, 2015 06:16AM

WORKING SOLUTION!!!

Just click on system tray

Apache>Service>Service install
Start all services

Options: ReplyQuote
Re: WampServer doesn't start on Windows 10
Posted by: phirow (---.17-1.cable.virginm.net)
Date: August 15, 2015 04:55PM

WINDOWS 10
My solution
You have to remove wamp completely, I used REVO UNINSTALLER which remove all files. Check that there is NO Wamp Folder on the c:/ drive. empty trash bin.
Go to windows and install all the c++ visuals and updates (for what ever system you have).
restart machine every time it tells you to, Download a fresh wamp and install. Start wamp, it should go orange,
Go to windows programs (turn features on / off and remove remove IIS SERVICE, reboot the machine, restart wamp and bingo it goes green!!!!!!!!!!.
I know that this seems along way round but it worked for me after trying all the suggestions on here.
REMEMBER TO DO BACKUPS OF YOUR WORK!!! BUT THIS WINDOWS AFTER ALL.
Phirow

Options: ReplyQuote
Re: WampServer doesn't start on Windows 10
Posted by: barnabas1984 (62.232.30.---)
Date: August 24, 2015 09:59AM

Mine was caused by Skype using Port 80. To fix, I opened Task Manager and closed Skype and then Restarted Wamp and it worked.

Options: ReplyQuote
Re: WampServer doesn't start on Windows 10
Posted by: Otomatic (Moderator)
Date: August 24, 2015 10:31AM

Hi,

For Skype: Checks to be made if you have a problem point N°03
And apply ALL other points to avoid future problems.

------------------------------------------------------------------------------------------------------------
(W7 Pro 64 bit)-Wampserver 3.0.9 32 bit - Apache 2.4.27 - PHP 7.1.8/7.0.22/5.6.31 - MySQL 5.7.19 - MariaDB 10.2.7
Wampserver 3.0.9 64 bit - Apache 2.4.27 - PHP 7.1.8/7.0.22/5.6.31 - MySQL 5.7.19 - MariaDB 10.2.7
PhPMyAdmin 4.7.3 - MysqlDumper 1.24.5

Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: WampServer doesn't start on Windows 10
Posted by: RiggsFolly (---.as43234.net)
Date: August 24, 2015 12:59PM

Hello phirow,

Quote

install all the c++ visuals

Not sure what you ment by this, just to clarify, you dont need to install Visual Studio, you just need the MSVC Runtime libraries.

See point 20 of this Checks to be made if you have a problem

---------------------------------------------------------------------------------------------
(Windows 7 Pro 32bit) (Wampserver 3.0.6 32bit)
<Apache 2.4.23/2.2.31> <PHP 7.1.2/7.0.16/5.6.28/5.5.38/5.4.45/5.3.29> <MySQL 5.7.10/5.6.17/5.5.28>
<MariaDB 10.1.21> <phpMyAdmin4.6.5.2> <MySQL Workbench 6.3.6.511>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin -- WAMPServer alternate Repo
-?-?-?- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -?-?-?-

Options: ReplyQuote
Pages: 12Next
Current Page: 1 of 2


Sorry, only registered users may post in this forum.