PHP Extensions List -- Don't Have a Green Checkmark
Posted by: Len_Jacobson (---.hsd1.ca.comcast.net)
Date: November 17, 2014 06:17PM

I added 'xDebug' to my WAMP PHP environment, but I don't see a green checkmark next to 'php_xdebug' in the list of PHP extensions. Instead, I see (what I would call) a red "construction triangle" with an exclamation sign inside the triangle.

What exactly does that symbol mean?

When I run 'phpinfo()', the 'xdebug' section looks correct to me, AND the text, "with Xdebug v2.2.6", appears next to the "Zend Engine 2" icon early in the 'phpinfo()' output.

In general, how does one get rid of that "construction triangle" next to a PHP extension -- I have two other PHP extensions with that symbol, and I have one PHP extension with a red square symbol next to it.

Thank you.

Options: ReplyQuote
Re: PHP Extensions List -- Don't Have a Green Checkmark
Posted by: Otomatic (Moderator)
Date: November 17, 2014 07:18PM

Hi,

/!\ (Triangle) This triangle can say two things:
- The extension cannot be loaded by 'extension=php_xdebug.dll' in php.ini. Must be loaded by 'zend_extension='. It can not be enabled or disabled by PHP Extensions menu.
- The 'xxxx.dll' extension file exists but there is no 'extension="xxxx.dll' line in php.ini.

The red square means that the line 'extension="xxxx.dll' exists in php.ini file but there is no "xxxx.dll' file in ext/ directory.

In the next version of WampServer (Mine is currently in Version 2.5.14) by clicking on the line where there is a triangle or a red square, an explanatory message will be given.

------------------------------------------------------------------------------------------------------------
(W7 Pro 64 bit)-Wampserver 3.0.9 32 bit - Apache 2.4.26 - PHP 7.1.6/7.0.20/5.6.30 - MySQL 5.7.18 - MariaDB 10.2.6
Wampserver 3.0.9 64 bit - Apache 2.4.26 - PHP 7.1.6/7.0.20/5.6.30 - MySQL 5.7.18 - MariaDB 10.2.6
PhPMyAdmin 4.7.1 - MysqlDumper 1.24.5

Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: PHP Extensions List -- Don't Have a Green Checkmark
Posted by: Len_Jacobson (---.hsd1.ca.comcast.net)
Date: November 17, 2014 07:27PM

Thanks very much for this explanation.


In my case, I DO have a 'zend_extension' setting at the very end of my 'php.ini' file and it does correctly point to the '.dll' file for 'xdebug'. So I don't know why the triangle appears.

But thank you for responding to this issue.

Options: ReplyQuote
Re: PHP Extensions List -- Don't Have a Green Checkmark
Posted by: RiggsFolly (---.as43234.net)
Date: November 17, 2014 08:30PM

Len,


XDEBUG comes as part of WAMPServer's basic install. You do not have to do anything extra.
Look at the bottom of the php.ini and its already there.

If you have added an extension= for XDEBUG, remove it, it is not loaded that way.

---------------------------------------------------------------------------------------------
(Windows 7 Pro 32bit) (Wampserver 3.0.6 32bit)
<Apache 2.4.23/2.2.31> <PHP 7.1.2/7.0.16/5.6.28/5.5.38/5.4.45/5.3.29> <MySQL 5.7.10/5.6.17/5.5.28>
<MariaDB 10.1.21> <phpMyAdmin4.6.5.2> <MySQL Workbench 6.3.6.511>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin -- WAMPServer alternate Repo
-?-?-?- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -?-?-?-

Options: ReplyQuote
Re: PHP Extensions List -- Don't Have a Green Checkmark
Posted by: Len_Jacobson (---.hsd1.ca.comcast.net)
Date: November 17, 2014 09:29PM

I thought just as you said that 'xdebug' was automatically a part of WAMP server. But after installing Wamp 2.5, I saw there was no 'xdebug'. The 'php.ini' file does not have the word "xdebug" in it.

So it only appears because I added it in a "zend_extension" setting.

Options: ReplyQuote
Re: PHP Extensions List -- Don't Have a Green Checkmark
Posted by: RiggsFolly (---.as43234.net)
Date: November 17, 2014 09:43PM

You should find these lines at the bottom of the php.ini file and the phpForApache.ini file.

; XDEBUG Extension

zend_extension = "c:/wamp/bin/php/php5.5.12/zend_ext/php_xdebug-2.2.5-5.5-vc11.dll"
;
[xdebug]
xdebug.remote_enable = off
xdebug.profiler_enable = off
xdebug.profiler_enable_trigger = off
xdebug.profiler_output_name = cachegrind.out.%t.%p
xdebug.profiler_output_dir = "d:/wamp/tmp"
xdebug.show_local_vars=0

And the xdebug dll is in the folder named on the zend_extension line

If not then you do not have a complete install!!!



Although now I look again, you did not specify which version of WAMPServer you had installed??

---------------------------------------------------------------------------------------------
(Windows 7 Pro 32bit) (Wampserver 3.0.6 32bit)
<Apache 2.4.23/2.2.31> <PHP 7.1.2/7.0.16/5.6.28/5.5.38/5.4.45/5.3.29> <MySQL 5.7.10/5.6.17/5.5.28>
<MariaDB 10.1.21> <phpMyAdmin4.6.5.2> <MySQL Workbench 6.3.6.511>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin -- WAMPServer alternate Repo
-?-?-?- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -?-?-?-

Options: ReplyQuote
Re: PHP Extensions List -- Don't Have a Green Checkmark
Posted by: Len_Jacobson (---.hsd1.ca.comcast.net)
Date: November 17, 2014 10:15PM

I installed wamp server 2.5 which came with PHP 5.5. I, however, need PHP 5.4 so I followed instructions that you provided me to install an older version, namely PHP 5.4.33. That installation was installed without a problem.

In my php.ini file (and 'phpForApache.ini'), there was no mention of 'xdebug' until I entered the 'zend_extension' line at the bottom of the file. I have now included the lines you provided me.

After restarting the servers, I still have the unwanted triangle next to 'php_xdebug-2.2.6-5.4-vc9' in the PHP extensions list.

Options: ReplyQuote
Re: PHP Extensions List -- Don't Have a Green Checkmark
Posted by: RiggsFolly (---.as43234.net)
Date: November 18, 2014 01:34AM

Right, I had forgotten you had installed another version of PHP, sol look at the phpForApache.ini file that came with php5.5.? and the original install.

That is how you add XDEBUG. You do not add an extension= with all the other extensions parameters!

You add XDEBUG as I showed above and as it was done in the version of PHP that came with the originally installed version of PHP.

You will need to download a version of XDEBUG that is compatible with PHP5.4 which I belive is php_xdebug-2.2.5-5.4-vc9.dll


The reason you have the unwanted triangle is that you have added a 'extension=something' with the other set of extension= paramters. REMOVE IT.

---------------------------------------------------------------------------------------------
(Windows 7 Pro 32bit) (Wampserver 3.0.6 32bit)
<Apache 2.4.23/2.2.31> <PHP 7.1.2/7.0.16/5.6.28/5.5.38/5.4.45/5.3.29> <MySQL 5.7.10/5.6.17/5.5.28>
<MariaDB 10.1.21> <phpMyAdmin4.6.5.2> <MySQL Workbench 6.3.6.511>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin -- WAMPServer alternate Repo
-?-?-?- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -?-?-?-

Options: ReplyQuote
Re: PHP Extensions List -- Don't Have a Green Checkmark
Posted by: Len_Jacobson (---.hsd1.ca.comcast.net)
Date: November 18, 2014 02:02AM

I did download 'xdebug' from [xdebug.org] then clicked on "custom installation instructions". They then ask you paste in the output of 'phpinfo()' that was run on your server. I did that and the next page that appeared gave me explicit instructions to do the installation of 'xdebug'.

They provided a link to download what they deemed to be the correct version of 'xdebug', and in my case it was 'php_xdebug-2.2.6-5.4-vc9.dll'. They then told me the directory in which to put that '.dll' file. It was:

C:\wamp\bin\php\php5.4.33\ext

I did that. They then gave me the text of the 'zend_extension' parameter to set in the two .ini files. I did that.

Here are the last lines of my 'php.ini' (and 'phpForApache.ini') file:

[ionCube]
zend_extension = "C:/wamp/www/TestServer/events/ioncube/ioncube_loader_win_5.4.dll"

[XDEBUG]
zend_extension = "C:/wamp/bin/php/php5.4.33/ext/php_xdebug-2.2.6-5.4-vc9.dll"

I have the 'ionCube' parameter defined first because the instructions for 'ionCube' say that it must be the first among any 'zend_extension' lines.

I do not know what exactly you meant by your last sentence in which you said I had added a 'extension=something' with the other set of extension = parameters. Can you explain that?

Options: ReplyQuote
Re: PHP Extensions List -- Don't Have a Green Checkmark
Posted by: RiggsFolly (---.as43234.net)
Date: November 18, 2014 09:32AM

Ok right now I see whats going on.

In a WAMP installation, for example if you look at the version of PHP that came with the original install. They put the XDEBUG dll into a folder called /wamp/bin/php/php5.4.33/zend_ext

And of course change the zend_extension line accordingly.


This way when wampmanager does it checks, it will not see a DLL in the '/wamp/bin/php/php5.4.33/ext` folder that does not have a corresponding entry in the extension= list.

Remember, the XDEBUG helper is a generic tool, not the gospel.

If you remove the xdebug dll from the ext folder and put it where I suggest, the offending icon will disappear, and xdebug will still work.

---------------------------------------------------------------------------------------------
(Windows 7 Pro 32bit) (Wampserver 3.0.6 32bit)
<Apache 2.4.23/2.2.31> <PHP 7.1.2/7.0.16/5.6.28/5.5.38/5.4.45/5.3.29> <MySQL 5.7.10/5.6.17/5.5.28>
<MariaDB 10.1.21> <phpMyAdmin4.6.5.2> <MySQL Workbench 6.3.6.511>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin -- WAMPServer alternate Repo
-?-?-?- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -?-?-?-

Options: ReplyQuote
Re: PHP Extensions List -- Don't Have a Green Checkmark
Posted by: Len_Jacobson (---.hsd1.ca.comcast.net)
Date: November 18, 2014 04:18PM

I moved the 'xdebug' DLL file out of

C:/wamp/bin/php/php5.4.33/ext/

and into

C:/wamp/bin/php/php5.4.33/zend_ext/

I then changed the 'php.ini' file (and 'phpForApache.ini' file) so that the last section reads:

[XDEBUG]
zend_extension = "C:/wamp/bin/php/php5.4.33/zend_ext/php_xdebug-2.2.6-5.4-vc9.dll"

I restarted the wamp servers.

Unfortunately, the triangle symbol still is shown by this extension.

Let me remind you that from the very first time I installed 'xdebug', the 'phpinfo()' output shows 'xdebug' as having been installed. Here is the 'xdebug' section. Perhaps you can see something that I am missing:


xdebug
xdebug support enabled
Version 2.2.6
IDE Key LEN$

Supported protocols Revision
DBGp - Common DeBuGger Protocol $Revision: 1.145 $

Directive Local Value Master Value
xdebug.auto_trace Off Off
xdebug.cli_color 0 0
xdebug.collect_assignments Off Off
xdebug.collect_includes On On
xdebug.collect_params 0 0
xdebug.collect_return Off Off
xdebug.collect_vars Off Off
xdebug.coverage_enable On On
xdebug.default_enable On On
xdebug.dump.COOKIE no value no value
xdebug.dump.ENV no value no value
xdebug.dump.FILES no value no value
xdebug.dump.GET no value no value
xdebug.dump.POST no value no value
xdebug.dump.REQUEST no value no value
xdebug.dump.SERVER no value no value
xdebug.dump.SESSION no value no value
xdebug.dump_globals On On
xdebug.dump_once On On
xdebug.dump_undefined Off Off
xdebug.extended_info On On
xdebug.file_link_format no value no value
xdebug.idekey no value no value
xdebug.max_nesting_level 100 100
xdebug.overload_var_dump On On
xdebug.profiler_aggregate Off Off
xdebug.profiler_append Off Off
xdebug.profiler_enable Off Off
xdebug.profiler_enable_trigger Off Off
xdebug.profiler_output_dir \ \
xdebug.profiler_output_name cachegrind.out.%p cachegrind.out.%p
xdebug.remote_autostart Off Off
xdebug.remote_connect_back Off Off
xdebug.remote_cookie_expire_time 3600 3600
xdebug.remote_enable Off Off
xdebug.remote_handler dbgp dbgp
xdebug.remote_host localhost localhost
xdebug.remote_log no value no value
xdebug.remote_mode req req
xdebug.remote_port 9000 9000
xdebug.scream Off Off
xdebug.show_exception_trace Off Off
xdebug.show_local_vars Off Off
xdebug.show_mem_delta Off Off
xdebug.trace_enable_trigger Off Off
xdebug.trace_format 0 0
xdebug.trace_options 0 0
xdebug.trace_output_dir \ \
xdebug.trace_output_name trace.%c trace.%c
xdebug.var_display_max_children 128 128
xdebug.var_display_max_data 512 512
xdebug.var_display_max_depth 3 3

Options: ReplyQuote
Re: PHP Extensions List -- Don't Have a Green Checkmark
Posted by: RiggsFolly (---.as43234.net)
Date: November 18, 2014 04:45PM

Ok,

This is a persistant little begger is it not!

Can I just check that you also made sure that in the phpForAPache.ini you removed the

extension=xdebug....

Or whatever it may have said.


And if that is the case, can you try doing

right click wampmanager -> refresh

Does that cure it.

---------------------------------------------------------------------------------------------
(Windows 7 Pro 32bit) (Wampserver 3.0.6 32bit)
<Apache 2.4.23/2.2.31> <PHP 7.1.2/7.0.16/5.6.28/5.5.38/5.4.45/5.3.29> <MySQL 5.7.10/5.6.17/5.5.28>
<MariaDB 10.1.21> <phpMyAdmin4.6.5.2> <MySQL Workbench 6.3.6.511>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin -- WAMPServer alternate Repo
-?-?-?- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -?-?-?-

Options: ReplyQuote
Re: PHP Extensions List -- Don't Have a Green Checkmark
Posted by: Len_Jacobson (---.hsd1.ca.comcast.net)
Date: November 18, 2014 06:44PM

There is no "extension=xdebug ..." line at all in either 'php.ini' nor in 'phpForApache.ini'.

I did the refresh and could not believe then what I saw when I right-clicked on the wamp icon in the SysTray and did the 'refresh'.

After that, the 'php_xdebug ...' line is totally missing from the list of PHP extensions!!!

Yet, the output of 'phpinfo()' is unchanged, showing 'xdebug' to be instlaled.

Can that be right?

Options: ReplyQuote
Re: PHP Extensions List -- Don't Have a Green Checkmark
Posted by: RiggsFolly (---.as43234.net)
Date: November 18, 2014 07:59PM

Finally, At Last, Hoo Bloomin ray, eventually, yabababaDOO !

CORRECT.

XDEBUG is a ZEND_EXTENSION and not a normal PHP extension. IT SHOULD NOT SHOW IN THE NORMAL LIST OF EXTENSIONS!!!!!!!

You know I think he's got it.... No... Yes I think he has.

---------------------------------------------------------------------------------------------
(Windows 7 Pro 32bit) (Wampserver 3.0.6 32bit)
<Apache 2.4.23/2.2.31> <PHP 7.1.2/7.0.16/5.6.28/5.5.38/5.4.45/5.3.29> <MySQL 5.7.10/5.6.17/5.5.28>
<MariaDB 10.1.21> <phpMyAdmin4.6.5.2> <MySQL Workbench 6.3.6.511>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin -- WAMPServer alternate Repo
-?-?-?- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -?-?-?-

Options: ReplyQuote
Re: PHP Extensions List -- Don't Have a Green Checkmark
Posted by: Len_Jacobson (---.hsd1.ca.comcast.net)
Date: November 18, 2014 08:03PM

Thanks so much for your help!!!

Len

Options: ReplyQuote
Re: PHP Extensions List -- Don't Have a Green Checkmark
Posted by: RiggsFolly (---.as43234.net)
Date: November 18, 2014 08:06PM

Your welcome,

Excuse the slight brevity.

---------------------------------------------------------------------------------------------
(Windows 7 Pro 32bit) (Wampserver 3.0.6 32bit)
<Apache 2.4.23/2.2.31> <PHP 7.1.2/7.0.16/5.6.28/5.5.38/5.4.45/5.3.29> <MySQL 5.7.10/5.6.17/5.5.28>
<MariaDB 10.1.21> <phpMyAdmin4.6.5.2> <MySQL Workbench 6.3.6.511>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin -- WAMPServer alternate Repo
-?-?-?- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -?-?-?-

Options: ReplyQuote
Re: PHP Extensions List -- Don't Have a Green Checkmark
Posted by: ashwinisanth (---.wifi.nat.warwick.ac.uk)
Date: May 31, 2017 12:16PM

I have installed the wamp server in my laptop and when I tried to view the PHP extensions I found only the triangle symbol instaed of green tick please help me with it I am completely new to this.

Options: ReplyQuote
Re: PHP Extensions List -- Don't Have a Green Checkmark
Posted by: RiggsFolly (Moderator)
Date: May 31, 2017 01:44PM

Please start a NEW Thread and answer all these question as part of your question READ (and answer) BEFORE YOU ASK A QUESTION

---------------------------------------------------------------------------------------------
(Windows 7 Pro 32bit) (Wampserver 3.0.6 32bit)
<Apache 2.4.23/2.2.31> <PHP 7.1.2/7.0.16/5.6.28/5.5.38/5.4.45/5.3.29> <MySQL 5.7.10/5.6.17/5.5.28>
<MariaDB 10.1.21> <phpMyAdmin4.6.5.2> <MySQL Workbench 6.3.6.511>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin -- WAMPServer alternate Repo
-?-?-?- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -?-?-?-

Options: ReplyQuote


Sorry, only registered users may post in this forum.