Apache service not starting after localhost port change
Posted by: windsor59 (---.dsl.wlfrct.sbcglobal.net)
Date: May 10, 2014 01:54AM

Well, I really did not want to start another thread about changing localhost port numbers or problems with services not running but I'm at wits end right now!
The issue:

I did all the changes to the various config and script files per Rigg's sticky after installing WampServer 2.4.4 in a clean install on Windows 32 bit system.I do development in Visual Studio so I have IIS7.0 running on port 80 and don't want to disable it.

After editing httpd.conf file to listen to port 100 I started up WampServer and everything worked fine: Icon status Green and server online and I could navigate to WampServer page by specifying localhost:100 and I could also launch phpMyadmin from there.

After trying with no success to configure Wamp to open localhost on port 100 automatically by following suggestions found while perusing this forum I came across this thread - [forum.wampserver.com] and followed the procedure to edit the wampmanager.tpl file (after saving a copy of the original).

I tried this but to no avail - I still ended up opening IIS on port 80 when navigating to localhost from the menu and the Orange icon indicating that the Apache service was not running. I deleted the modified wampmanger.tpl and restored the original file, cleared the browser cache and started the WampServer.

The icon is Orange again and WampServer indicates that the Apache service is not running (tried clicking the Start/Resume Service but it will not start. I looked at all the other config files and they all look the same as when all was fine in the world. I looked at the Apache log file and no errors are shown so I'm stumped at the moment.

Is there any other change to a conf file that wampmanager.tpl makes that I'm not thinking of - I scanned through the file but I'm getting blurry eyed now so needed to reach out to the forum! Any help would be awesome!

Options: ReplyQuote
Re: Apache service not starting after localhost port change
Posted by: windsor59 (---.dsl.wlfrct.sbcglobal.net)
Date: May 10, 2014 02:51AM

Well, never mind - I found the problem via the Windows Event viewer; somehow the closing '>' got dropped from the Directory directive in the cgi ID module in the httpd.conf file. That little error caused me some serious frustration as I'm unclear as to how that occurred!!

There must be a way to configure the Wampserver to navigate to a port; doing so via the httpd.conf file does not work in version 2.4.4. although I can't figure out why that is - am I missing something else that works in tandem with httpd.conf file to configure this? Something to ponder.....

Options: ReplyQuote

Sorry, only registered users may post in this forum.